You can ignore it. This warning is an artifact of out of date code in the Kittehcoin wallet. The new Lynx wallet available here has this warning removed. We strongly recommend you no longer use the older Kittehcoin wallet as transactions may not get confirmed properly.